Z10_STL100-2_10.0.10.822 - Downloads - BlackBerryOS.com

Downloads: Z10_STL100-2_10.0.10.822

Z10_STL100-2_10.0.10.822

Uploaded by AgentBlackBerry - 04-13-2013
Author Author AgentBlackBerry
File Size File Size 1.39 GB
Downloads Downloads 878
Download
Leaked OS 10.0.10.822 for the BlackBerry Z10 Liverpool (STL100-2). This OS is for the STL100-2 Z10 model only! That is the LTE GSM Z10 model for Europe and other regions. If you are not sure what model your Z10 is, type "myver" in a text field with your Z10's keyboard, or check the About > Category: OS section in the Settings menu.

Warning: Please remember that this IS NOT an official release operating system. If you wish to install this OS keep in mind that this may cause your phone to not function correctly. Also remember, upon loading this OS, it will wipe your device clean. Make sure you back up your device before loading it. Otherwise, you will lose all your data.


Images

None

Comments

hobgoblin
04-13-2013 at 10:58 AM
tried to download this file a few times now, actually since a few day, since it was announced in CB first...
anyway the download starting fast, but always stalling around 11% !!
not going to continuing even if let alowne over night.
hobgoblin
04-13-2013 at 11:03 AM
actually the size of the file is "BB10_0_10.116.472185.exe (1.39 GB)"
Joe Jerde
04-13-2013 at 01:42 PM
Thanks @hobgoblin, I've added the size of the file to the download.
mosheys
04-15-2013 at 03:29 PM
Can you please create a mirror link? maga is down
stunnar
04-18-2013 at 03:38 PM
I'm failing to download the file, my BB Z10 still runs the OS it came with so I have no clue on how to update it, is it the same way we updating the BB 9900? Thankx
classaffaire
04-26-2013 at 06:35 PM
Use Google Chrome to download it.
classaffaire
04-26-2013 at 06:40 PM
Mega works perfect with Google Browser
Diversion042
05-02-2013 at 07:16 AM
So I am here after trying 10.1.0.1483 which was fine apart from I could not load BB Bridge. I wanted an update as I had the 'can't send email without red no entry sign' problem and my browser was crashing all over the place. Anyway 4 days in and all is running very well at the moment. All my apps have reloaded and updated and email and browsing seems much better. I had sideloaded an amazon music app that isn't in app world for BB10, and haven't tried reloading that yet, but hopefully it will be OK.