Page 2 of 3 FirstFirst 123 LastLast
Results 9 to 16 of 17

  1. #9
    Join Date
    Mar 2009
    Location
    Atwater, California,
    Posts
    1,507
    Quote Originally Posted by jlevy73 View Post
    I had a similar problem as my bricked my phone bad on OS 5.0. As I downgraded I had the same issue. Here is what I did to resolve it.

    1. Wiped the phone clean with either BBSAK or JL Commander
    2. Reinstall .148

    This resolved the issue for me.

    the great J comes to the rescue, do what he says and see if it fixes it!



  2. #10
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    And Joe if you can find the options icon, do a security wipe but going into options, security, BB button and then wipe.

  3. #11
    Join Date
    Mar 2009
    Device
    Z10
    Posts
    13
    it may sound dumb but make sure he is not using the device while its on the magnetic pouch.. that happened to someone i know and those were the symptoms



  4. #12
    Join Date
    Apr 2009
    Location
    venezuela
    Device
    onyx
    OS
    .423
    Posts
    219

    hey

    Quote Originally Posted by Kris View Post
    the great J comes to the rescue, do what he says and see if it fixes it!
    hey bro thats what i did, installed .148 with .148 radio from 9500 i wiped the phone and did all u said , but after installing it went black again, now it s working but lets see if it keeps doing the same, otherwise ill have to buy a new screen.
    by the way anyone know how can i see what kind of screen do i have cus there are couple of screen and only 1 works for the phone either version 1 or 2...

  5. #13
    Join Date
    May 2009
    Location
    Volunteer State
    Device
    None
    OS
    Virtuous 3.26.605.1*
    Posts
    1,977
    Quote Originally Posted by joe11 View Post
    hey bro thats what i did, installed .148 with .148 radio from 9500 i wiped the phone and did all u said , but after installing it went black again, now it s working but lets see if it keeps doing the same, otherwise ill have to buy a new screen.
    by the way anyone know how can i see what kind of screen do i have cus there are couple of screen and only 1 works for the phone either version 1 or 2...
    So you say that you have a list of the screens that might fit your device?

    Can you list out the part#'s?

    While you are doing that, I'll try to find a parts breakdown list.



  6. #14
    Join Date
    Apr 2009
    Location
    venezuela
    Device
    onyx
    OS
    .423
    Posts
    219
    no bro is not a list, there are only 2 screens that could fit the phone, but only 1 works

  7. #15
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    Quote Originally Posted by joe11 View Post
    no bro is not a list, there are only 2 screens that could fit the phone, but only 1 works
    Joe I would recommend checking out horizonwireless.com

    That's where a lot of people have their phones fixed and they will make sure you get the right screen.

  8. #16
    Join Date
    Apr 2009
    Location
    Western Mass
    PIN
    311F860E
    Device
    Storm 9550
    Posts
    358
    That just happened to my phone. If you squeeze it or twist the phone slightly does the screen turn on? I brought mine back to VZW and they replaced it.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •