Cant Send Text Messages!!
Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Thread: Cant Send Text Messages!!

  1. #1
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times

    Question Cant Send Text Messages!!

    Hello everyone! I have an unlocked Blackberry Storm 9530 running with the hybrid os. I cant send text messages. This was happening before and after the update to hybrid os. When i send a message i get a red X. I can receive them fine. I use T-mobile service. Could someone please help me? I would really appreciate it? I have the blackberry service data plan that t-mobile provides and i tried doing the reset that involves taking out the battery. Please help!!




  2. #2
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    Quote Originally Posted by Aleeya View Post
    Hello everyone! I have an unlocked Blackberry Storm 9530 running with the hybrid os. I cant send text messages. This was happening before and after the update to hybrid os. When i send a message i get a red X. I can receive them fine. I use T-mobile service. Could someone please help me? I would really appreciate it? I have the blackberry service data plan that t-mobile provides and i tried doing the reset that involves taking out the battery. Please help!!
    Welcome to BBOS Aleeya. Have you tried re-registering your HRT. On your storm go to Options/Advanced Options/Host Routing Table. Then hit your bb button and select Register Now. This should fix your problem.

  3. #3
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    Quote Originally Posted by Shanepark2 View Post
    Welcome to BBOS Aleeya. Have you tried re-registering your HRT. On your storm go to Options/Advanced Options/Host Routing Table. Then hit your bb button and select Register Now. This should fix your problem.
    I tried that and still did not work.

  4. #4
    Neolantis's Avatar
    Neolantis is offline BlackBerryOS Grand Master Follow Neolantis On Twitter
    Join Date
    Feb 2009
    Location
    Massachusetts
    Posts
    2,578
    Liked
    188 times
    Quote Originally Posted by Aleeya View Post
    I tried that and still did not work.
    Welcome Aleeya, I had made this post in a different thread I finally found.

    Take your time and see if this helps you...Please post back here so I and others know if this has solved your problem or not


    Quote Originally Posted by Neolantis View Post
    Ok, so download Crackutil

    For Microsoft Vista, an additional step is needed after installation on all versions. Right click on the CrackUtil icon and scroll to Properties. Select Properties and then on the next panel, select Compatability and then click Run this program as an administrator. This only need to be done once right after installation. Note the check in the Run this program as an administrator box.

    If you do want to do this, let me know when your done. I'll keep checking back
    Quote Originally Posted by Neolantis View Post
    Please see attachments below for T-Mobile Service Books.



    Download/Save the Service Books to your desktop, right click on the Zip file and select "Extract All". Inside is one .ipd file. You'll come back to it in Step 2.

    tmo_servicebooks.zip

    STEP #1


    Connect the Storm (and leave connected throughout the procedure) to pc and open CrackUtil. Enter your password if you use one. Select the File Manipulation Tab, then select Retrieve File Listing. Scroll down until you see the module net_rim_bb_browser_daemon Click on it and select "Remove File From Device".You will get a Grid Index Out of Range message at this point. That's normal, close CrackUtil. The Storm will be in the process of rebooting and may have an "Uncaught Exception Error" This is normal.



    STEP #2


    Now, Open Desktop Manager and go to Back up and Restore>Advanced. You will see the Storm's databases in the box on the right. Over the box on the left, select File>Open. Locate and Double click on the Service books .ipd file you downloaded and extracted earlier. They should now be in the left box. Single click to highlight them in the left box and hit the bottom of the two middle buttons to transfer them to the Storm. When that is done, return to the Main Menu, then close Desktop Manager.



    STEP #3


    Open CrackUtil. Go to the File Manipulation Tab, select Load File to Device A window will open containing the net_rim_bb_browser_daemon module you removed. Double click on it to replace it. When thats done you can Exit CrackUtil. You can now disconnect from pc. The Storm will be in the process of rebooting.



    You should have a Fully Functional Browser now. Resend your email service books from T-Mobile to restore your email. Also you need TCP configurations in Options>Advanced Options>TCP. APN should say wap.voicestream.com Nothing under user name or password.

    If you are using an unlocked Verizon Storm and have "Activation Required" on your home screen or your phone number displays incorrectly, Dial # # 000000 (Send). In the Menu add your phone number and select save. The device will reboot and activate.
    Click the Like button to thank me.
    Retired Administrator--I never try anything, I just do it.....Wanna try me?--

  5. #5
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    It still didnt work. I was wondering when I go to Options>SMS Text, I noticed the Service Center Callback number is my own number. Shouldn't it be Tmobile service center number which is +12063130004. I tried to enter the number it says "Invalid Service Specified". I dont know if it matters but it looks suspicious to me.

  6. #6
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    so other than your sms text, everything else works? browser, email, mms?

  7. #7
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    Yes everything else works perfectly fine. I dont understand whats going on..

  8. #8
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    With t-mobile, You use a sim card? Have you you tried removing the sim, rebooting the phone and replacing the sim. I did a google search about your service center number because I think thats part of your problem. Unlike verizon, you just can't dial *228 to get your sms back. +12063130004 is the correct service number.

  9. #9
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    Thats what im trying to do and it wont let me change the number. It says Invalid Service Specified. this really sucks big time

  10. #10
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    Maybe the sms.cod id corrupt. Got to Crackutil and overwrite it with this one. Its the one from my phone. Not sure it will do anything, but worth a try.
    Attached Files Attached Files

  11. #11
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    I found out the problem was my SIM Card!! I did overwrite my sms.cod file and the same thing was happening. So my brother has tmobile also and I put his card in my phone and I was able to send messages. I went to the tmobile store, got another SIM Card, popped it in, and I was able to send messages. Perhaps my SIM card was outdated because I have had the same one since 2002. But thank you so much Shanepark2 and Neolantis for helping me I do appreciate it!!

  12. #12
    Kris's Avatar
    Kris is offline BlackBerryOS Champion Follow Kris On Twitter
    Join Date
    Mar 2009
    Location
    Atwater, California,
    Posts
    1,507
    Liked
    1 times
    Quote Originally Posted by Aleeya View Post
    I found out the problem was my SIM Card!! I did overwrite my sms.cod file and the same thing was happening. So my brother has tmobile also and I put his card in my phone and I was able to send messages. I went to the tmobile store, got another SIM Card, popped it in, and I was able to send messages. Perhaps my SIM card was outdated because I have had the same one since 2002. But thank you so much Shanepark2 and Neolantis for helping me I do appreciate it!!
    Sims cards tend to go bad a lot lol when i use to have ATT i remember having to get 5 just in one year lol

  13. #13
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    no problem, glad you got it working.

  14. #14
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    The lady at Tmobile looked at me like I was crazy for thinking that a SIM card would go bad. Prior to my Storm I had a Tmobile Wing and I had crazy issues with texting, I suspected them it was the SIM card but the rep insisted it wasnt. Today I basically had to demand a new one.

  15. #15
    Neolantis's Avatar
    Neolantis is offline BlackBerryOS Grand Master Follow Neolantis On Twitter
    Join Date
    Feb 2009
    Location
    Massachusetts
    Posts
    2,578
    Liked
    188 times
    Quote Originally Posted by Aleeya View Post
    I found out the problem was my SIM Card!! I did overwrite my sms.cod file and the same thing was happening. So my brother has tmobile also and I put his card in my phone and I was able to send messages. I went to the tmobile store, got another SIM Card, popped it in, and I was able to send messages. Perhaps my SIM card was outdated because I have had the same one since 2002. But thank you so much Shanepark2 and Neolantis for helping me I do appreciate it!!
    very welcome, i didn't even think of that cause i pulled mine out and stored it.
    Click the Like button to thank me.
    Retired Administrator--I never try anything, I just do it.....Wanna try me?--

  16. #16
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    My next question is how to get rid of the verizon wireless "splash screen", "boot logo", or whatever they call it when turning on the phone or starting the browser? Is it possible? I would love to replace it with a tmobile one. LOL

  17. #17
    Aleeya is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Location
    Detroit
    PIN
    304DF521
    Device
    Storm 9530
    OS
    4.7.0.114
    Posts
    10
    Liked
    0 times
    Quote Originally Posted by Neolantis View Post
    very welcome, i didn't even think of that cause i pulled mine out and stored it.
    I was suspicious about it

  18. #18
    Kris's Avatar
    Kris is offline BlackBerryOS Champion Follow Kris On Twitter
    Join Date
    Mar 2009
    Location
    Atwater, California,
    Posts
    1,507
    Liked
    1 times
    Quote Originally Posted by Aleeya View Post
    My next question is how to get rid of the verizon wireless "splash screen", "boot logo", or whatever they call it when turning on the phone or starting the browser? Is it possible? I would love to replace it with a tmobile one. LOL
    Im not sure if you can but shane should be able to help you more with that, he knows crackutil VERY well lol

  19. #19
    Shane's Avatar
    Shane is offline BlackBerryOS Champion
    Join Date
    Mar 2009
    Location
    Pa
    PIN
    yes
    OS
    5.0.xxx/.40
    Posts
    1,626
    Liked
    0 times
    Quote Originally Posted by KristopherF View Post
    Im not sure if you can but shane should be able to help you more with that, he knows crackutil VERY well lol
    hafta look into this... Never really took note, because I have verizon and am used to it. It used to be easy with moto non-smart phones because the software was alot easier to tinker with. I will see what I can come up with.

  20. #20
    Kris's Avatar
    Kris is offline BlackBerryOS Champion Follow Kris On Twitter
    Join Date
    Mar 2009
    Location
    Atwater, California,
    Posts
    1,507
    Liked
    1 times
    Quote Originally Posted by Shanepark2 View Post
    hafta look into this... Never really took note, because I have verizon and am used to it. It used to be easy with moto non-smart phones because the software was alot easier to tinker with. I will see what I can come up with.
    If I remember right when I was on CB there was someone trying to do it but the phone wouldn't let them cause it said it was locked or something.

    I would think verizon has that locked but then again you never know

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •