Page 1 of 5 123 ... LastLast
Results 1 to 8 of 36

  1. #1
    snmemx is offline BlackBerryOS Inspired
    Join Date
    Mar 2009
    Device
    Storm 9530
    OS
    .148 (.132 radio) w BBCM 7.2
    Posts
    216

    Battery Question

    I've been reading about how a good way to improve battery life on the Storm is completely drain the battery so the battery chip will reset itself. I've let the thing run down until the radio turned off and the phone finally shut itself off.

    I waited 15-20min, then plugged it into the charger and started the phone again, however even when plugged in, I can't get the radio to turn on (says not enough battery available to start the radio). So here are my questions:

    1. is it normal for the radio not to run with a dead battery, even if the phone is plugged in and charging?

    2. does anyone know if it sounds like I've let the battery discharge enough to reset the internal chip on the battery?

    Thanks!



  2. #2
    Laney's Avatar
    Laney is offline BlackBerryOS Master
    Join Date
    May 2009
    Posts
    2,386
    the radio when only come back up once the battery reaches a certain percentage... i think its 10% but dont quote me.... happens to me all the time

    there is a way to get it to turn back on though.... if you go to options>advanced options>wireless upgrade>check for upgrades if kinda fools the phone to turn the radio back on

  3. #3
    jlevy73's Avatar
    jlevy73 is offline BlackBerryOS Einstein
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    Quote Originally Posted by snmemx View Post
    I've been reading about how a good way to improve battery life on the Storm is completely drain the battery so the battery chip will reset itself. I've let the thing run down until the radio turned off and the phone finally shut itself off.

    I waited 15-20min, then plugged it into the charger and started the phone again, however even when plugged in, I can't get the radio to turn on (says not enough battery available to start the radio). So here are my questions:

    1. is it normal for the radio not to run with a dead battery, even if the phone is plugged in and charging?

    2. does anyone know if it sounds like I've let the battery discharge enough to reset the internal chip on the battery?

    Thanks!
    Yes it is very normal for the radio not to run after letting the battery drain until dead. Even after charging it may take a good 20 minutes for battery to charge enough for the radio to turn back on.

    Yes, you did it right. If the phone shut off the internal memory should be reset.



  4. #4
    jnepsa's Avatar
    jnepsa is offline BlackBerryOS Wizard
    Join Date
    Apr 2009
    Location
    ohio
    PIN
    ch me then
    Device
    9550 Storm 2
    OS
    5.0.0.428
    Posts
    4,387
    god i hate when you beat me jl and welcome to bbos laney

  5. #5
    snmemx is offline BlackBerryOS Inspired
    Join Date
    Mar 2009
    Device
    Storm 9530
    OS
    .148 (.132 radio) w BBCM 7.2
    Posts
    216
    Thanks for the help everyone! I've finished charging it back to 100% and hopefully the full discharge will help with the battery life issue.



  6. #6
    jlevy73's Avatar
    jlevy73 is offline BlackBerryOS Einstein
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    Quote Originally Posted by snmemx View Post
    Thanks for the help everyone! I've finished charging it back to 100% and hopefully the full discharge will help with the battery life issue.
    Please do let us know if it worked out for you.

  7. #7
    snmemx is offline BlackBerryOS Inspired
    Join Date
    Mar 2009
    Device
    Storm 9530
    OS
    .148 (.132 radio) w BBCM 7.2
    Posts
    216
    Quote Originally Posted by jlevy73 View Post
    Please do let us know if it worked out for you.
    I'll run my regular routine for charging at night/use tomorrow so I'll post back...but I've got a question for you based on your info...it shows V5-132. Does that mean you're running hybrid V5 over OS 132? (I know it's off-topic but figured I'd ask rather than bugging you w a PM). Thanks!

  8. #8
    jlevy73's Avatar
    jlevy73 is offline BlackBerryOS Einstein
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    Quote Originally Posted by snmemx View Post
    I'll run my regular routine for charging at night/use tomorrow so I'll post back...but I've got a question for you based on your info...it shows V5-132. Does that mean you're running hybrid V5 over OS 132? (I know it's off-topic but figured I'd ask rather than bugging you w a PM). Thanks!
    It means I am running V5 with the SFI from 132.

Page 1 of 5 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •