Page 3 of 3 FirstFirst 123
Results 17 to 23 of 23

  1. #17
    Join Date
    Sep 2009
    Location
    Edinburgh, Scotland
    Device
    Blackberry Storm 9520
    OS
    5.0.0.973
    Posts
    134
    I am getting a replacement tomorrow and so went the whole hog and completely wiped my phone and re-installed the OS.

    Guess what? The problem of the locked keys was gone after that. It would appear that the issue may lie with a process monopolising the CPU long enough for there to be a delay in the unlock response time.



  2. #18
    Join Date
    Apr 2009
    Location
    Charlotte
    Device
    Bold 9930
    OS
    7.0.0.353
    Posts
    701
    Try and get a Canada device, they seem to have less problems.

  3. #19
    Join Date
    May 2009
    Location
    Athens, GA
    Device
    Blackberry Storm 9550
    OS
    .320
    Posts
    278
    Wow, I never had as severe as issues with the s1 or s2 as you guys are posting. I must be lucky i guess . I've also noticed that the screen ONLY responds to fingers. This girl in my class was playing around with it and couldn't click it sometimes and then i noticed she had long fingernails. As a guy, this is never a problem, but the device can tell the slight difference between when a majority of your nail is pressing and when your actual digit is pressing.



  4. #20
    Join Date
    Jul 2009
    PIN
    GED your IP ;)
    Device
    9700/9000
    OS
    >>.421/.411
    Posts
    205
    Quote Originally Posted by bensminger View Post
    Is anyone having issues with the Storm 2 touch screen? At various times, my touch screen doesn't appear to "click" in the bottom right-hand corner on the end call button. I read that the piezo electronic technology doesn't engage sometimes if the device is locked but my device hasn't been locked.

    Yeah thats something I noticed and didn't care for about the S2's but if you just press a bit higher on the buttons on the bottom they work a lot better....Kinda something I figured they would perfect better...

  5. #21
    Join Date
    Jun 2009
    Location
    Miami Florida
    Device
    9700/9530
    OS
    5.0.0.421/5.0.0.419
    Posts
    60
    Just when you thought Rim was in the right direction.
    Don't get me wrong, I know that you will always have defects on an item.
    But something like this should have been fixed.



  6. #22
    Join Date
    Apr 2009
    Location
    Cleveland, Ohio
    PIN
    30F7ADA8
    Device
    9550 Storm 2
    OS
    5.0.0.320
    Posts
    179
    my first device had a great keyboard but the phone audio issue sucked. this one is getting testy with the keyboard. sometimes the end button doesnt click and other times it sounds like a crunch when being clicked. i will give it a week or so and see if it pisses me off enough to get my third device.

  7. #23
    Join Date
    Oct 2009
    Location
    Cincinnati
    Device
    Storm2
    OS
    5.0.0.320
    Posts
    8
    same here.. 1st storm2 had a bad headphone jack, 2nd one the call button wont click.. waiting on #3... Went through 6 storm1.. just give me a phone that works!

    Quote Originally Posted by T-Rob View Post
    Good to see that I'm not the only one with this problem...my "call" button has this issue.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •