is anyone else having issues with the send button click?
Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Thread: is anyone else having issues with the send button click?

  1. #1
    greg's Avatar
    greg is offline BlackBerryOS Inspired Follow greg On Twitter Add greg on Facebook
    Join Date
    Oct 2009
    Location
    Calgary
    PIN
    311E271E
    Device
    Storm 9550
    OS
    9800 sfi os 6.0.0.249, not!
    Posts
    149
    Liked
    0 times

    is anyone else having issues with the send button click?

    I seem to have intermittent issues with my send button, sometimes it wont click and sometimes its fine...trying to decide if i should doa this device or not.

    thanks




  2. #2
    jlevy73's Avatar
    jlevy73 is offline BlackBerryOS Einstein
    Join Date
    Mar 2009
    Location
    Los Angeles, CA
    Device
    9630/9550/9530/
    Posts
    8,538
    Liked
    6 times
    Quote Originally Posted by greg View Post
    I seem to have intermittent issues with my send button, sometimes it wont click and sometimes its fine...trying to decide if i should doa this device or not.

    thanks
    You should get it replaced. One of mine had the same problem and it got real annoying quick.

  3. #3
    systaff3 is offline BlackBerryOS Noobie
    Join Date
    Oct 2009
    Device
    storm 2
    OS
    5.0.320
    Posts
    9
    Liked
    0 times
    i am having the SAME problem...

  4. #4
    greg's Avatar
    greg is offline BlackBerryOS Inspired Follow greg On Twitter Add greg on Facebook
    Join Date
    Oct 2009
    Location
    Calgary
    PIN
    311E271E
    Device
    Storm 9550
    OS
    9800 sfi os 6.0.0.249, not!
    Posts
    149
    Liked
    0 times
    i think I will have Telus send me a new one then.

  5. #5
    Le0_Br4zuC4's Avatar
    Le0_Br4zuC4 is offline BlackBerryOS Gifted
    Join Date
    Jul 2009
    Location
    Miami
    PIN
    30FB551F
    Device
    BlackBerry Stor
    OS
    5.0.0.320
    Posts
    398
    Liked
    0 times
    A friend of mine did have that problem and he got his phone replaced. you should do the same

    Follow me on Twiter
    [/URL][/CENTER][/SIZE]
    Le0_Br4zUc4 - BlackBerry Storm 2 9550 Running 5.0.0.428

  6. #6
    jnepsa's Avatar
    jnepsa is offline BlackBerryOS Wizard
    Join Date
    Apr 2009
    Location
    ohio
    PIN
    ch me then
    Device
    9550 Storm 2
    OS
    5.0.0.428
    Posts
    4,387
    Liked
    5 times
    Moved to the 9550/9520 forum

  7. #7
    jungleland26 is offline BlackBerryOS Enthusiast
    Join Date
    Jul 2009
    Location
    Philly
    Device
    Storm 2 + 9630
    Posts
    63
    Liked
    0 times
    I think there's an issue with the electronic click....It seems to go in to sleep mode and then there's a slight delay when you wake it up....

    If you've noticed that when the battery is out, you can't click the screen...


    Am I on the right track here?

  8. #8
    tbcpn's Avatar
    tbcpn is offline BlackBerryOS Inspired
    Join Date
    Apr 2009
    Location
    Portland, OR
    Device
    Storm2 9550 / Bold 9650 (VZW)
    OS
    5.0.0.??? Hybrid?
    Posts
    140
    Liked
    0 times
    Quote Originally Posted by jungleland26 View Post
    I think there's an issue with the electronic click....It seems to go in to sleep mode and then there's a slight delay when you wake it up....

    If you've noticed that when the battery is out, you can't click the screen...


    Am I on the right track here?
    Occasional "hard buttons" seem to be a fairly common issue--I've seen reference to this on a number of forums. Indeed, my S2 has this issue occasionally, altho it's generally the BB or the Return button and it only seems to occur when the phone is laying flat on a table.

    My sense (and it's only that as I don't understand the inner workings of the screen hardware / software interactions) is that it is a software/firmware issue versus a hardware issue, at least with my phone. I'm on my second S2 (first one had an poor fitting battery), and both had the occasional and random hard button issue.

  9. #9
    dlsolo's Avatar
    dlsolo is offline BlackBerryOS Inspired Follow dlsolo On Twitter
    Join Date
    Sep 2009
    Location
    North Carolina
    PIN
    the tail on the iPhone
    Device
    9550
    OS
    5.0.0.607
    Posts
    152
    Liked
    0 times
    Quote Originally Posted by tbcpn View Post
    Occasional "hard buttons" seem to be a fairly common issue--I've seen reference to this on a number of forums. Indeed, my S2 has this issue occasionally, altho it's generally the BB or the Return button and it only seems to occur when the phone is laying flat on a table.

    My sense (and it's only that as I don't understand the inner workings of the screen hardware / software interactions) is that it is a software/firmware issue versus a hardware issue, at least with my phone. I'm on my second S2 (first one had an poor fitting battery), and both had the occasional and random hard button issue.
    I had to quote you on this because this is exactly what I'm thinking. Only when I have my BB flat on a surface do most of my issues come alive. I've not had a problem when I'm holding upright (horizontal or vertical).
    dlsolo@blackberryos.com
    GTalk: dlsolo@gmail.com
    GWave: dlsolo@googlewave.com

  10. #10
    jason.steelman1's Avatar
    jason.steelman1 is offline BlackBerryOS Inspired Follow jason.steelman1 On Twitter
    Join Date
    Oct 2009
    Location
    Yadkinville, NC
    PIN
    TO Beans
    Device
    Storm 2 - 9550
    OS
    .713
    Posts
    101
    Liked
    0 times
    Mine only go 'hard' when I've got the screen locked. Occassionally I'll have an issue with it not wanting to click, but again that's when its laying flat on a table, OR I've got the screen locked. Actually makes sense to me that it does that, I thought it was a feature given the consistency of occurence for me.
    Come on you Gunners!! Up the Arsenal!

  11. #11
    allentb is offline BlackBerryOS Friend
    Join Date
    Mar 2009
    Device
    Storm2 9550
    Posts
    12
    Liked
    0 times
    Just returned my S2 for a new one. Mine too was having the hard button problem. Verizon store gave hassle on returning it and told me that I was the first one they've heard of having this problem. (LOL) So if your having this problem let them know about it so maybe something can be done.

  12. #12
    joshjamie's Avatar
    joshjamie is offline BlackBerryOS Addict Follow joshjamie On Twitter
    Join Date
    Sep 2009
    Location
    Kitchener
    PIN
    Bell
    Device
    Z10
    OS
    10.0.10.85
    Posts
    545
    Liked
    15 times
    Having the same issue here as well. Until i read this thread, all I have been doing is adding the address into my contacts and I could then send and reply to emails from people who were not in my address book. However, after reading this this morning, I contacted Bell Mobility, explained my problem to the tech and got the party line. After talking to a supervisor, my replacement storm (not a rebuild) is on its way at no cost.

    Thanks BBOS!!! We're keeping the carriers honest to some extent!!

    :You_Rock_Emoticon:
    Last edited by joshjamie; 11-30-2009 at 04:40 PM.

  13. #13
    greg's Avatar
    greg is offline BlackBerryOS Inspired Follow greg On Twitter Add greg on Facebook
    Join Date
    Oct 2009
    Location
    Calgary
    PIN
    311E271E
    Device
    Storm 9550
    OS
    9800 sfi os 6.0.0.249, not!
    Posts
    149
    Liked
    0 times
    Quote Originally Posted by joshjamie View Post
    Having the same issue here as well. Until i read this thread, all I have been doing is adding the address into my contacts and I could then send and reply to emails from people who were not in my address book. However, after reading this this morning, I contacted Bell Mobility, explained my problem to the tech and got the party line. After talking to a supervisor, my replacement storm (not a rebuild) is on its way at no cost.

    Thanks BBOS!!! We're keeping the carriers honest to some extent!!

    :You_Rock_Emoticon:
    Bell doesn't have the 9550...what are you talking about

  14. #14
    greg's Avatar
    greg is offline BlackBerryOS Inspired Follow greg On Twitter Add greg on Facebook
    Join Date
    Oct 2009
    Location
    Calgary
    PIN
    311E271E
    Device
    Storm 9550
    OS
    9800 sfi os 6.0.0.249, not!
    Posts
    149
    Liked
    0 times
    My issue isn't when the device is laying flat on a table it is sometimes when my device is in my hand working fine for menu, back, end but send refuses to click... until I push so hard I feel like the glass is about the break and end up in my thumb.

  15. #15
    Miata492's Avatar
    Miata492 is offline BlackBerryOS Enthusiast Follow Miata492 On Twitter
    Join Date
    Mar 2009
    Location
    CT, USA
    PIN
    OT NOIR
    Device
    Storm2 9550
    OS
    5.0.0.607 A_E_hybrid
    Posts
    99
    Liked
    0 times
    Quote Originally Posted by tbcpn View Post
    it's generally the BB or the Return button and it only seems to occur when the phone is laying flat on a table.
    that is the only time i have an issue - when lying flat on a hard surface.
    VZW Storm2 9550 5.0.0.607 A_E_hybrid

  16. #16
    Spidersweb's Avatar
    Spidersweb is offline BlackBerryOS Inspired
    Join Date
    Mar 2009
    Location
    EST
    PIN
    312C58A8
    Device
    Strom 9550
    OS
    5.0.0.607/672
    Posts
    175
    Liked
    1 times
    Has anyone noticed if this issue is fixed with a Hybrid upgrade?
    Just curious. :22:
    All the World is a Stage..., and if you don't act right, I'm cutting off your Mic. :147:

  17. #17
    joshjamie's Avatar
    joshjamie is offline BlackBerryOS Addict Follow joshjamie On Twitter
    Join Date
    Sep 2009
    Location
    Kitchener
    PIN
    Bell
    Device
    Z10
    OS
    10.0.10.85
    Posts
    545
    Liked
    15 times
    Quote Originally Posted by greg View Post
    Bell doesn't have the 9550...what are you talking about

    The 9530.

  18. #18
    jungleland26 is offline BlackBerryOS Enthusiast
    Join Date
    Jul 2009
    Location
    Philly
    Device
    Storm 2 + 9630
    Posts
    63
    Liked
    0 times
    Quote Originally Posted by allentb View Post
    Just returned my S2 for a new one. Mine too was having the hard button problem. Verizon store gave hassle on returning it and told me that I was the first one they've heard of having this problem. (LOL) So if your having this problem let them know about it so maybe something can be done.

    If I had a dollar for every time I heard "we haven't encountered that problem and no reports of it".....I'd be LOADED...



    Quote Originally Posted by greg View Post
    My issue isn't when the device is laying flat on a table it is sometimes when my device is in my hand working fine for menu, back, end but send refuses to click... until I push so hard I feel like the glass is about the break and end up in my thumb.

    Same here...Not just when flat on surface...

    Has anyone noticed if this issue is fixed with a Hybrid upgrade?
    Just curious.
    Nope...still happening on multiple hybrid versions have not been on an OS/hybrid in which it did not happen...

  19. #19
    tbcpn's Avatar
    tbcpn is offline BlackBerryOS Inspired
    Join Date
    Apr 2009
    Location
    Portland, OR
    Device
    Storm2 9550 / Bold 9650 (VZW)
    OS
    5.0.0.??? Hybrid?
    Posts
    140
    Liked
    0 times
    Quote Originally Posted by jungleland26 View Post
    ...Nope...still happening on multiple hybrid versions have not been on an OS/hybrid in which it did not happen...
    Ditto here. I've run probably five different hybrids on my S2 9550. But, great phone all-in-all.

  20. #20
    markhunsaker's Avatar
    markhunsaker is offline BlackBerryOS Friend Follow markhunsaker On Twitter
    Join Date
    Dec 2009
    Location
    Idaho Falls, ID
    PIN
    32FBD315
    Device
    Bold 9930
    OS
    BBOS7
    Carrier
    Verizon
    Posts
    19
    Liked
    5 times
    It's a well known problem with a lot of Storm2s. You can either get it replaced, or you can wait for an OS update. I noticed that my first Storm2 had some click problems...I also had installed and invisible shield on it (from Zagg.com). When I took off the shield just before I took it back in to Verizon, my click issues weren't as bad. So if you have a screen protector, that may be part of it.

    But it is a known issue and you can take it back and they'll exchange it.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •