Playbook won't charge at all
Results 1 to 6 of 6

Thread: Playbook won't charge at all

  1. #1
    Cera Walker is offline BlackBerryOS Noobie Follow Cera Walker On Twitter Add Cera Walker on Facebook Add Cera Walker on Google+ Visit Cera Walker's Youtube Channel
    Join Date
    Dec 2012
    Location
    Texas
    PIN
    2882650A
    Device
    Torch 9810
    OS
    7.1.0 Bundle 998
    Carrier
    T-Mobile
    Posts
    9
    Liked
    1 times

    Question Playbook won't charge at all

    Hello Everyone,

    I need some help. I had tried to charge my pb yesterday. I had the power on and plugged in the charger no charge symbol showed. I had powered off and no response. The day before it was charging fine. But, even trying to charge it again there was still no response. Please help! Need my pb for school. Thanks.




  2. #2
    Harmeling68's Avatar
    Harmeling68 is offline Forum Moderator Follow Harmeling68 On Twitter Add Harmeling68 on Facebook Add Harmeling68 on Google+ Add Harmeling68 on Linkedin
    Join Date
    Dec 2010
    Location
    Gainesville, FL
    PIN
    3343247B
    Device
    Black Q10
    OS
    10.2.1.1925
    Carrier
    Verizon
    Posts
    522
    Liked
    142 times
    Hello! Sorry to hear about your troubles. Your Playbook sounds very important to you. I am assuming that you are using the standard charger that came with it and not the magnetic charger or a charging dock?

    So, the first thing I would check is to make sure that the outlet that you have it plugged into is a working outlet. Have you tried other outlets?

    Secondly, make sure that the charger is working. Do you have a phone that you can test the charger with?

    Please post back with what you find out. If you don't have a magnetic charger for it, I would encourage you to get one. I've been reading about the standard charging ports getting messed up and I'd hate for that to happen to yours.

  3. #3
    Cera Walker is offline BlackBerryOS Noobie Follow Cera Walker On Twitter Add Cera Walker on Facebook Add Cera Walker on Google+ Visit Cera Walker's Youtube Channel
    Join Date
    Dec 2012
    Location
    Texas
    PIN
    2882650A
    Device
    Torch 9810
    OS
    7.1.0 Bundle 998
    Carrier
    T-Mobile
    Posts
    9
    Liked
    1 times
    Thanks for your reply. But, no I don't have the magnetic charger. I use the standard charger that came with my pb. I checked the outlet and it is working fine. However, when I plugged the standard charger in my phone it doesn't work. That's a problem. I also want to mention that my phone charger can also plug into my pb and I use to use that charger when I couldn't find my standard charger that goes with it and it would also charge my pb. So, I tried that and still no response. I hope I didn't break it.

  4. #4
    Harmeling68's Avatar
    Harmeling68 is offline Forum Moderator Follow Harmeling68 On Twitter Add Harmeling68 on Facebook Add Harmeling68 on Google+ Add Harmeling68 on Linkedin
    Join Date
    Dec 2010
    Location
    Gainesville, FL
    PIN
    3343247B
    Device
    Black Q10
    OS
    10.2.1.1925
    Carrier
    Verizon
    Posts
    522
    Liked
    142 times
    Sounds like a bad charger . Your phone charger should charge it, although slowly.

  5. #5
    Cera Walker is offline BlackBerryOS Noobie Follow Cera Walker On Twitter Add Cera Walker on Facebook Add Cera Walker on Google+ Visit Cera Walker's Youtube Channel
    Join Date
    Dec 2012
    Location
    Texas
    PIN
    2882650A
    Device
    Torch 9810
    OS
    7.1.0 Bundle 998
    Carrier
    T-Mobile
    Posts
    9
    Liked
    1 times
    I found the problem! I looked where I plug in the charger and I found one of the small metal piece sticking up inside. So, I used a needle to move it back down and it is working again. Thanks for your help. I will go get a magnetic charger though and stop using the standard charger so I don't have to worry about it again.
    Harmeling68 likes this.

  6. #6
    Harmeling68's Avatar
    Harmeling68 is offline Forum Moderator Follow Harmeling68 On Twitter Add Harmeling68 on Facebook Add Harmeling68 on Google+ Add Harmeling68 on Linkedin
    Join Date
    Dec 2010
    Location
    Gainesville, FL
    PIN
    3343247B
    Device
    Black Q10
    OS
    10.2.1.1925
    Carrier
    Verizon
    Posts
    522
    Liked
    142 times
    Yay! I am so glad you figured that out! Who would have thought to check that?!? Still, if you can, get yourself a magnetic charger. I've been reading quite a few post about charging ports getting messed up and the magnetic chargers will keep the port in good shape for using it to hook up to your computer. AND, rumors about RIM giving us the ability to use the usb port for usb's might become reality! Merry Christmas, God bless and have a Happy New Year!
    BB then, now, forever!

Similar Threads

  1. Playbook does not charge when charger plugged in
    By chevron1083 in forum BlackBerry PlayBook
    Replies: 7
    Last Post: 10-10-2012, 05:45 PM
  2. Play book did not charge
    By popleke1 in forum BlackBerry PlayBook
    Replies: 4
    Last Post: 08-06-2012, 08:08 PM
  3. 9530 on .230 will not charge
    By femBBuser in forum BlackBerry Storm 9530/9500
    Replies: 2
    Last Post: 10-01-2009, 12:39 PM
  4. Unable to charge???/
    By watkins in forum BlackBerry Storm 9530/9500
    Replies: 9
    Last Post: 08-12-2009, 02:46 AM
  5. battery won't charge, is it bad???
    By brohlijk in forum General BlackBerry Issues
    Replies: 9
    Last Post: 07-20-2009, 06:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •