Play book did not charge
Results 1 to 5 of 5

Thread: Play book did not charge

  1. #1
    popleke1 is offline BlackBerryOS Noobie
    Join Date
    Aug 2012
    Posts
    1
    Liked
    0 times

    Post Play book did not charge

    Hi everyone, i have a playbook for 3 months, but this morning i want to charge it but could not charge, it only shows the red light for 30 seconds and then go off again. can any one help me to solve this problem.

    thanks
    popleke1




  2. #2
    ducca683 is offline BlackBerryOS Noobie
    Join Date
    Jul 2011
    Device
    9800
    OS
    6,0
    Posts
    1
    Liked
    1 times
    Try charging (plugging charger in several times - 10ish) in short bursts: plug the cable, when light disappear, disconnect and then immediatelly connect charger again... When you get to 10th time (or near) try switching on your PlayBook -with charger still connected... This routine helped me few weeks back, as I left my playbook in the office, switched on and it completely discharged. I almost started disassembling it and searching for a replacement battery. PlayBook (and many other devices which control charge by the software) don;t really appreciate discharge to zero... So show them some love and never leave them alone, not plugged in!

    Hope this helps, let us know the results.
    ice2921 likes this.

  3. #3
    ToraxCefiro's Avatar
    ToraxCefiro is offline BlackBerryOS Gifted Follow ToraxCefiro On Twitter
    Join Date
    Mar 2012
    Location
    Manila Philippines
    Device
    BOLD 9900
    Carrier
    Globe Telecom, Inc.
    Posts
    373
    Liked
    96 times
    Quote Originally Posted by ducca683 View Post
    Try charging (plugging charger in several times - 10ish) in short bursts: plug the cable, when light disappear, disconnect and then immediatelly connect charger again... When you get to 10th time (or near) try switching on your PlayBook -with charger still connected... This routine helped me few weeks back, as I left my playbook in the office, switched on and it completely discharged. I almost started disassembling it and searching for a replacement battery. PlayBook (and many other devices which control charge by the software) don;t really appreciate discharge to zero... So show them some love and never leave them alone, not plugged in!

    Hope this helps, let us know the results.
    My friend also encountered this problem before.. He was so devastated as he thought his PlayBook wouln't operate anymore but he just prolonged his patience and did what ducca683 has done on his PlayBook anda fter doing so, it went back to normal again. It was a lesson learned. Remember, do not at any point to leave your PlayBook completely discharged else same issue will happen again Try charging it when it reaches 20% just to make sure
    ToraxCefiro
    Click the LIKE button in the bottom right of a post to say thanks!
    Downloads Center[B] | Rules and Guidelines[B] l

  4. #4
    daddybenoit is offline BlackBerryOS Noobie
    Join Date
    Oct 2011
    Device
    playbook
    OS
    6
    Posts
    1
    Liked
    1 times
    I had the same problem, I read on another forum that a combination of holding down the volume and power buttons might help. I then did this in combination with plugging in the charger (a couple times) after which a battery image appeared on screen and it began to charge again.
    ice2921 likes this.

  5. #5
    ice2921's Avatar
    ice2921 is offline BlackBerryOS Grand Master Follow ice2921 On Twitter
    Join Date
    Sep 2010
    Location
    USA
    Device
    Z10
    OS
    10.0.10.684
    Carrier
    AT&T
    Posts
    2,544
    Liked
    751 times
    Quote Originally Posted by daddybenoit View Post
    I had the same problem, I read on another forum that a combination of holding down the volume and power buttons might help. I then did this in combination with plugging in the charger (a couple times) after which a battery image appeared on screen and it began to charge again.
    What that does is a hard reset.

Similar Threads

  1. Unable to charge while powered on
    By jrett in forum BlackBerry PlayBook
    Replies: 2
    Last Post: 04-10-2012, 12:29 AM
  2. Just Got Home - Replaced S1 with S2 no charge
    By P3Designs in forum BlackBerry Storm 2 9550/9520
    Replies: 5
    Last Post: 11-01-2009, 05:05 PM
  3. 9530 on .230 will not charge
    By femBBuser in forum BlackBerry Storm 9530/9500
    Replies: 2
    Last Post: 10-01-2009, 12:39 PM
  4. Unable to charge???/
    By watkins in forum BlackBerry Storm 9530/9500
    Replies: 9
    Last Post: 08-12-2009, 02:46 AM
  5. battery won't charge, is it bad???
    By brohlijk in forum General BlackBerry Issues
    Replies: 9
    Last Post: 07-20-2009, 06:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •