I can not get Data Service for my Bold 9900, OS 7.1 and below is not accepted. Is there any way I can get around it, or this is it ? Thank you.