Results 1 to 6 of 6
  1. #1
    Join Date
    Dec 2011
    Location
    USA
    Device
    Z10
    OS
    Messed up
    Carrier
    T-Mobile
    Posts
    49

    Problem with 4G.

    Please be gentle, I'm fairly new. I have a 9900 that was factory unlocked, but I have T-Mobil as a service provider. Their 4G signal cell tower where I'm located works perfectly, I am able to make/ receive calls, however my data is being sorted/ provided on the edge/EDGE band so data is transferred at a snails pace. T-Mobil support is like talking to a wall. Can anybody help please. Thanks



  2. #2
    Join Date
    Oct 2011
    Posts
    1
    U might have to go into the moblie network settings and turn your network selection mode to manual and try to find your 4G connection. And also try different places where u live. I also have the 9900 for T-Mobile and sometimes I get EDGE depending where I'm at. Hopefully this helps you.

  3. #3
    Join Date
    Dec 2011
    Location
    USA
    Device
    Z10
    OS
    Messed up
    Carrier
    T-Mobile
    Posts
    49
    Thanks, I've been all over town (Orlando) with countless hard starts but top no avail, it's getting frustrating. Thanks though, I might have to return it as much as I'd hate to.



  4. #4
    Join Date
    Sep 2010
    Location
    USA
    Device
    Z10
    OS
    10.0.10.684
    Carrier
    AT&T
    Posts
    2,544
    If you are are T-mobile you can try to re-register the APN:
    1. From the Home screen, select Options.
    2. Select Advanced options.
    3. Select TCP.
    4. In the APN field, type: epc.t-mobile.com
    Register the device and initiate the download of service books, you can do that here:

    T-Mobile Support Community: Register the device on the wireless network using the Host Routing Table - BlackBerry (All Devices)

    Hope this helps.

  5. #5
    Join Date
    Dec 2011
    Location
    USA
    Device
    Z10
    OS
    Messed up
    Carrier
    T-Mobile
    Posts
    49
    Thanks, just got off the phone with RIM and was informed there was no way of achieving 4g service from a "non" T-Mobile phone. Thanks you though.



  6. #6
    Join Date
    Feb 2012
    Device
    bold 9900
    OS
    7.0
    Posts
    1
    sin problemas

Similar Threads

  1. os problem or battery problem or phone problem??
    By tomen in forum BlackBerry Bold 9700
    Replies: 9
    Last Post: 06-28-2012, 09:08 AM
  2. os problem or battery problem or phone problem??
    By tomen in forum General BlackBerry Issues
    Replies: 0
    Last Post: 08-25-2011, 02:51 AM
  3. BBM Problem ..
    By Youssef in forum BlackBerry Native Apps
    Replies: 2
    Last Post: 04-07-2011, 02:31 AM
  4. sms problem
    By bambino in forum BlackBerry Bold 9700
    Replies: 8
    Last Post: 05-11-2010, 08:50 PM
  5. problem with dm5.0
    By moedaddy2121 in forum BlackBerry Storm 9530/9500
    Replies: 40
    Last Post: 05-20-2009, 10:37 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
This website uses cookies
We use cookies to store session information to facilitate remembering your login information, to allow you to save website preferences, to personalise content and ads, to provide social media features and to analyse our traffic. We also share information about your use of our site with our social media, advertising and analytics partners.