Page 2 of 2 FirstFirst 12
Results 9 to 14 of 14

  1. #9
    Join Date
    May 2009
    Device
    Blackberry Bold 9700/ iPhone 3GS
    OS
    5.0.0.442 / 3.1.2
    Posts
    50
    I'm wondering if the different screen versions have anything to do with this. I know that you're supposed to replace your LCD with the same model if it ever breaks which mine did. I have the 003/004 (located on the back of the LCD). I have not experienced this problem and it's probably not worth taking the phone apart to find out if it could be 001/004 or 002/004 LCD's causing the problem.



  2. #10
    Join Date
    Nov 2009
    Device
    bold
    Posts
    4
    Gonna give 509 a shot. I'll post the after the install!

    Fingers crossed!

  3. #11
    Join Date
    Nov 2009
    Device
    bold
    Posts
    4
    509 seems to have solved the issue but i gotta go back to 411 since i need the eastasia pack..... but for all of those out there that won't be needing asian language input, i think you guys can give it a shot.... Good luck all!



  4. #12
    Join Date
    Nov 2009
    Device
    bold
    Posts
    4
    Actually the snowy screen issue is still here on 509......

  5. #13
    Join Date
    Jul 2009
    Location
    Grand Cayman, Cayman
    OS
    10.1.0.
    Carrier
    LIME
    Posts
    79
    I had this problem once, did a couple hard resets and it went away... not sure if i was lucky or it fixed whatever was wrong, but it did go away.



  6. #14
    Join Date
    Aug 2009
    Location
    Raleigh, NC
    PIN
    's and nee
    Device
    9550
    OS
    5.0.0.607
    Posts
    937
    I would recommend contacting the carrier and arranging for a replacement device.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •