Now works with 5.0