I installed BBSAK 1.5 and was able to use successfully, or so I thought. When I tried loading a .cod for youtube I received the following error:

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.
************** Exception Text **************
System.MissingMethodException: Method not found: 'System.String System.Windows.Forms.OpenFileDialog.get_SafeFileNa me()'.
at BBSAK.Form1.Button3_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventAr gs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.O nMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.W ndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

After doing some investigation I found the above error is a common .net error. I checked what versions of .net our company is running and noticed we run 1.1 and 2.0. Even though on Rimgeeks.com it states you only need .net 2.0 to run v1.5 of BBSAK, I decided to install .net 3.5. Upon doing so I resolved my Method not found error and I was finally able to load my .cod. Maybe someone having a similar issue will find this post and it will help them.