Need Help: Blackberry 9860 Dead, displaying battery with Red X cross
Results 1 to 10 of 10

Thread: Need Help: Blackberry 9860 Dead, displaying battery with Red X cross

  1. #1
    sleetaino is offline BlackBerryOS Noobie
    Join Date
    Jan 2013
    Location
    Paris
    PIN
    284110d6
    Device
    9860
    OS
    7.0
    Posts
    5
    Liked
    0 times

    Need Help: Blackberry 9860 Dead, displaying battery with Red X cross

    My device asked me to upgrade which i did , few days after My Blackberry 9860 went off and refused to power on. Only blinking Red LED light for few seconds and after display a symbol of battery empty with red X sign crossing it. as battery drain.
    I ve tried diff ways to power it on but all to no avail. i tried using blackberry desktop software but when it gets to JVM installation it stops. and write blackberry device software not available..i have tried many ways. also downloaded an OS from AT&T and enter tru program file to App loader and stops also when it gets ARM and write d samething.
    Please i need assistance on how to power on my device blackberry 9860.
    Any contribution will be appreciated.
    Thank you

    Akin




  2. #2
    Harmeling68's Avatar
    Harmeling68 is offline Forum Moderator Follow Harmeling68 On Twitter Add Harmeling68 on Facebook Add Harmeling68 on Google+ Add Harmeling68 on Linkedin
    Join Date
    Dec 2010
    Location
    Gainesville, FL
    PIN
    3343247B
    Device
    Black Q10
    OS
    10.2.1.1925
    Carrier
    Verizon
    Posts
    554
    Liked
    147 times
    Sounds like a battery issue and not necessarily an os issue. Are you able to try another battery? Also, check the little battery pins on your phone to make sure you have a good connection.
    BB then, now, forever!

  3. #3
    sleetaino is offline BlackBerryOS Noobie
    Join Date
    Jan 2013
    Location
    Paris
    PIN
    284110d6
    Device
    9860
    OS
    7.0
    Posts
    5
    Liked
    0 times

    Dead Blackberry with red X on battery symbol

    Thanks for your response Harmeling68........., I ve tried many batteries and also clean the battery connection Pin in the device, all to no avail. i ve charged for many hours , remove and insert d battery again. and also i have tried to reload new OS but there is some thing wrong abt reconnecting to JVM, it wont load from there, i ve tried BLACKBERRY SOFTWARE MANAGER, also load via App loader , the computer is recognising my PIN as FFFFFFFF but when gets to reconnecting to JVM, it ll stop again and d battery with X , ll reappear on my dead blackberry screen,,, i tried to use BBSK but not seing my device, tried to use MCP to wipe and re load also but when i use MCP to wipe, the battery sign with X ll dissapear but my fone ll still blank i.e not power on, but when i try to reload OS it ll hang at reconnecting to JVM and the battery symbol with X, will re appear on my dead Blackberry...
    Anybody with solution , how to overcome this,,i ve tried everythin i could ...Pls Helppppppppppp!

  4. #4
    Walter66's Avatar
    Walter66 is offline BlackBerryOS Enthusiast Follow Walter66 On Twitter
    Join Date
    Jan 2010
    Location
    Florida
    PIN
    32fbf84f
    Device
    Z10,PB64
    OS
    10.09.422
    Carrier
    Verizon
    Posts
    78
    Liked
    28 times

    Not recommended but try?

    Quote Originally Posted by sleetaino View Post
    Thanks for your response Harmeling68........., I ve tried many batteries and also clean the battery connection Pin in the device, all to no avail. i ve charged for many hours , remove and insert d battery again. and also i have tried to reload new OS but there is some thing wrong abt reconnecting to JVM, it wont load from there, i ve tried BLACKBERRY SOFTWARE MANAGER, also load via App loader , the computer is recognising my PIN as FFFFFFFF but when gets to reconnecting to JVM, it ll stop again and d battery with X , ll reappear on my dead blackberry screen,,, i tried to use BBSK but not seing my device, tried to use MCP to wipe and re load also but when i use MCP to wipe, the battery sign with X ll dissapear but my fone ll still blank i.e not power on, but when i try to reload OS it ll hang at reconnecting to JVM and the battery symbol with X, will re appear on my dead Blackberry...
    Anybody with solution , how to overcome this,,i ve tried everythin i could ...Pls Helppppppppppp!
    I have had on occasion the issue of the JVM connection you you spoke of. Through trial and error , though not recommended, have found that disconnecting the USB when it hangs for a second or so and then plugging it back in invokes the JVM to reconnect. Hope this helps.
    Joe Jerde likes this.

  5. #5
    Harmeling68's Avatar
    Harmeling68 is offline Forum Moderator Follow Harmeling68 On Twitter Add Harmeling68 on Facebook Add Harmeling68 on Google+ Add Harmeling68 on Linkedin
    Join Date
    Dec 2010
    Location
    Gainesville, FL
    PIN
    3343247B
    Device
    Black Q10
    OS
    10.2.1.1925
    Carrier
    Verizon
    Posts
    554
    Liked
    147 times
    Quote Originally Posted by Walter66 View Post
    I have had on occasion the issue of the JVM connection you you spoke of. Through trial and error , though not recommended, have found that disconnecting the USB when it hangs for a second or so and then plugging it back in invokes the JVM to reconnect. Hope this helps.
    Oh wow! You are absolutely right Walter66! As soon as I read what you wrote, I realized that I've had the same experience. When installing a new os: It will get hung up, I'll disconnect the usb and reconnect and it picks right back up where it stopped from. Sleetaino, give it a go and post back with what you find.
    BB then, now, forever!

  6. #6
    sleetaino is offline BlackBerryOS Noobie
    Join Date
    Jan 2013
    Location
    Paris
    PIN
    284110d6
    Device
    9860
    OS
    7.0
    Posts
    5
    Liked
    0 times
    Thanks for all your response but ....Yea read that on forums too but I ve tried that several times but still the same, hanging at reconnecting JVM...

  7. #7
    Walter66's Avatar
    Walter66 is offline BlackBerryOS Enthusiast Follow Walter66 On Twitter
    Join Date
    Jan 2010
    Location
    Florida
    PIN
    32fbf84f
    Device
    Z10,PB64
    OS
    10.09.422
    Carrier
    Verizon
    Posts
    78
    Liked
    28 times
    Have you tried starting desktop manager with phone hooked up and rebooting the phone. In your case doing a battery pull. The desktop manager will look for your phone. You get a pop up that says update, repair or cancel? Click repair and on from there?

    - - - Updated - - -

    Just a curiosity what software are you running on your PC?
    Harmeling68 likes this.

  8. #8
    sleetaino is offline BlackBerryOS Noobie
    Join Date
    Jan 2013
    Location
    Paris
    PIN
    284110d6
    Device
    9860
    OS
    7.0
    Posts
    5
    Liked
    0 times
    Yes i ve tried that, and clicked on repaire and asked me to choose the OS that i want to install which i choosed 7.1 recommended but everything was loading fine until it got to reconnecting JVM...I removed battery and put bck, i changed usb port .. no solution yet

  9. #9
    Walter66's Avatar
    Walter66 is offline BlackBerryOS Enthusiast Follow Walter66 On Twitter
    Join Date
    Jan 2010
    Location
    Florida
    PIN
    32fbf84f
    Device
    Z10,PB64
    OS
    10.09.422
    Carrier
    Verizon
    Posts
    78
    Liked
    28 times
    Go to your device manager with your 9860 hooked to one of your USB ports. The one you use the most. Search for hardware connected to your PC and see if it is installed correctly. What software are you using? Have you recently upgraded to windows 8? You may need to reboot while you perform this action.
    Last edited by Walter66; 01-24-2013 at 05:10 PM.

  10. #10
    sleetaino is offline BlackBerryOS Noobie
    Join Date
    Jan 2013
    Location
    Paris
    PIN
    284110d6
    Device
    9860
    OS
    7.0
    Posts
    5
    Liked
    0 times
    i ll try that..Thanks

Similar Threads

  1. Replies: 0
    Last Post: 03-20-2012, 11:45 PM
  2. Dead Battery
    By Behrouz Haghighat in forum General BlackBerry Issues
    Replies: 5
    Last Post: 11-24-2011, 10:23 AM
  3. Battery life not displaying correctly
    By c0Ld in forum BlackBerry Storm 9530/9500
    Replies: 5
    Last Post: 05-22-2009, 08:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •